4480 entries · page 31 of 90

Attribute types

The fields an entry can hold: cn, mail, uidNumber, and several hundred more. Each has a syntax, matching rules, and an OID.

OIDNameDefined in
1.2.840.113556.1.4.1245globalAddressList Global-Address-List
1.2.840.113556.1.4.2047globalAddressList2 Global-Address-List2
2.5.21.10governingStructureRuleRFC 4512
1.2.840.113556.1.2.22governsID Governs-ID
1.2.840.113556.1.4.894gPCFileSysPath GPC-File-Sys-Path
1.2.840.113556.1.4.893gPCFunctionalityVersion GPC-Functionality-Version
1.2.840.113556.1.4.1348gPCMachineExtensionNames GPC-Machine-Extension-Names
1.2.840.113556.1.4.1349gPCUserExtensionNames GPC-User-Extension-Names
1.2.840.113556.1.4.1694gPCWQLFilter GPC-WQL-Filter
1.2.840.113556.1.4.891gPLink GP-Link
1.2.840.113556.1.4.892gPOptions GP-Options
1.3.6.1.4.1.2428.20.1.27gPosRecord
1.2.840.113556.1.4.152groupAttributes Group-Attributes
1.2.840.113556.1.4.166groupMembershipSAM Group-Membership-SAM
1.2.840.113556.1.4.345groupPriority Group-Priority
1.2.840.113556.1.4.344groupsToIgnore Groups-to-Ignore
1.2.840.113556.1.4.750groupType Group-Type
1.2.840.113556.1.2.14hasMasterNCs Has-Master-NCs
1.2.840.113556.1.2.15hasPartialReplicaNCs Has-Partial-Replica-NCs
2.5.18.9hasSubordinates
1.2.840.113556.1.2.402helpData16 Help-Data16
1.2.840.113556.1.2.9helpData32 Help-Data32
1.2.840.113556.1.2.327helpFileName Help-File-Name
1.2.840.113556.1.4.1780hideFromAB Hide-From-AB
1.3.6.1.4.1.2428.20.1.13hInfoRecord
1.3.6.1.4.1.2428.20.1.55HIPRecord
1.3.6.1.1.1.1.56historyData
1.2.840.113556.1.4.44homeDirectory Home-Directory
1.3.6.1.1.1.1.3homeDirectory unixHomeDirectory The absolute path to a user's home directory, handed to the login stack by SSSD or nss. RFC 2307 makes it mandatory on …
1.2.840.113556.1.4.45homeDrive Home-Drive
1.3.6.1.4.1.7165.2.1.10homeDrive
0.9.2342.19200300.100.1.20homePhone homeTelephone, homeTelephoneNumber, Phone-Home-PrimaryRFC 4524, RFC 1274
0.9.2342.19200300.100.1.39homePostalAddressRFC 4524, RFC 1274
1.2.840.113556.1.2.617homePostalAddress Address-Home
0.9.2342.19200300.100.1.9hostRFC 4524, RFC 1274
2.16.840.1.113730.3.8.3.17hostCApolicy
2.16.840.1.113730.3.8.3.8hostCategory
2.16.840.1.113730.3.8.7.12hostMask
2.5.4.51houseIdentifierRFC 4519, RFC 2256
1.3.6.1.4.1.2428.20.1.65HTTPSRecord
1.2.840.113556.1.4.219iconPath Icon-Path
2.16.840.1.113730.3.8.5.1idnsAllowDynUpdate
2.16.840.1.113730.3.8.5.11idnsAllowQuery
2.16.840.1.113730.3.8.5.13idnsAllowSyncPTR
2.16.840.1.113730.3.8.5.12idnsAllowTransfer
2.16.840.1.113730.3.8.5.15idnsForwarders
2.16.840.1.113730.3.8.5.14idnsForwardPolicy
2.16.840.1.113730.3.8.5.0idnsName
2.16.840.1.113730.3.8.5.17idnsPersistentSearch
2.16.840.1.113730.3.8.5.27idnsSecAlgorithm
← All categories