4480 entries · page 41 of 90

Attribute types

The fields an entry can hold: cn, mail, uidNumber, and several hundred more. Each has a syntax, matching rules, and an OID.

OIDNameDefined in
2.16.840.1.113730.3.1.2343legalName
1.2.840.113556.1.2.50linkID Link-ID
1.2.840.113556.1.4.269linkTrackSecret Link-Track-Secret
1.3.6.1.4.1.7165.2.1.1lmPassword
1.2.840.113556.1.4.160lmPwdHistory Lm-Pwd-History
1.2.840.113556.1.4.58localeID Locale-ID
1.2.840.113556.1.4.1353localizationDisplayId Localization-Display-Id
1.2.840.113556.1.4.817localizedDescription Localized-Description
1.2.840.113556.1.4.56localPolicyFlags Local-Policy-Flags
1.2.840.113556.1.4.457localPolicyReference Local-Policy-Reference
1.2.840.113556.1.4.222location Location
1.2.840.113556.1.4.60lockoutDuration Lockout-Duration
1.2.840.113556.1.4.61lockOutObservationWindow Lock-Out-Observation-Window
1.2.840.113556.1.4.73lockoutThreshold Lockout-Threshold
1.2.840.113556.1.4.662lockoutTime Lockout-Time
1.3.6.1.4.1.2428.20.1.29LocRecord
1.3.6.1.1.1.1.38loginFailedAttempts
1.3.6.1.1.1.1.4loginShell The path to the user's login shell. Point it at /usr/sbin/nologin or /bin/false and you have a directory account that …
1.3.6.1.4.1.7165.2.1.6logoffTime
1.2.840.113556.1.4.169logonCount Logon-Count
1.2.840.113556.1.4.64logonHours Logon-Hours
1.3.6.1.4.1.7165.2.1.5logonTime
1.2.840.113556.1.4.65logonWorkstation Logon-Workstation
1.2.840.113556.1.4.66lSACreationTime LSA-Creation-Time
1.2.840.113556.1.4.67lSAModifiedCount LSA-Modified-Count
1.3.6.1.1.1.1.22macAddress
1.2.840.113556.1.4.68machineArchitecture Machine-Architecture
1.2.840.113556.1.4.520machinePasswordChangeInterval Machine-Password-Change-Interval
1.2.840.113556.1.4.71machineRole Machine-Role
1.2.840.113556.1.4.459machineWidePolicy Machine-Wide-Policy
0.9.2342.19200300.100.1.3mail RFC822Mailbox, rfc822Mailbox, rfc822mailbox, E-mail-Addresses RFC 822 email address. IA5 string with a caseIgnore match, and multi-valued, which is how one person carries a primary …RFC 4524, RFC 1274
1.3.6.1.4.1.15347.2.111mailaccess
2.16.840.1.113730.3.1.12mailAccessDomain
1.2.840.113556.1.4.786mailAddress SMTP-Mail-Address
2.16.840.1.113730.3.1.14mailAutoReplyMode
2.16.840.1.113730.3.1.15mailAutoReplyText
1.3.6.1.4.1.10018.1.1.1mailbox
2.16.840.1.113730.3.1.16mailDeliveryOption
1.3.6.1.4.1.15347.2.110maildest
1.3.6.1.4.1.15347.2.100maildropRFC 1274
2.16.840.1.113730.3.1.31mailEnhancedUniqueMember
2.16.840.1.113730.3.1.17mailForwardingAddress
2.16.840.1.113730.3.1.18mailHost
2.16.840.1.113730.3.1.13mailLocalAddress mailAlternateAddressRFC 822
2.16.840.1.113730.3.1.19mailMessageStore
0.9.2342.19200300.100.1.47mailPreferenceOptionRFC 1274
2.16.840.1.113730.3.1.20mailProgramDeliveryInfo
2.16.840.1.113730.3.1.21mailQuota
1.3.6.1.4.1.7914.1.2.1.16mailQuotaCount
1.3.6.1.4.1.7914.1.2.1.15mailQuotaSize
← All categories