4480 entries · page 85 of 90

Attribute types

The fields an entry can hold: cn, mail, uidNumber, and several hundred more. Each has a syntax, matching rules, and an OID.

OIDNameDefined in
1.2.840.113556.1.4.822siteLinkList Site-Link-List
1.2.840.113556.1.4.821siteList Site-List
1.2.840.113556.1.4.512siteObject Site-Object
1.2.840.113556.1.4.513siteObjectBL Site-Object-BL
1.2.840.113556.1.4.494siteServer Site-Server
1.3.6.1.4.1.7165.2.1.17smbHome
2.5.4.4sn surname, surName, Surname, SN Surname. It subtypes the name attribute, so it inherits that syntax and matching, and like most name attributes it is …RFC 4519, RFC 2256
0.9.2342.19200300.100.1.30sOARecordRFC 1274
1.3.6.1.4.1.42.2.27.5.1.4SolarisAttrKeyValue
1.3.6.1.4.1.42.2.27.5.1.8SolarisAttrLongDesc
1.3.6.1.4.1.42.2.27.5.1.13SolarisAttrReserved1
1.3.6.1.4.1.42.2.27.5.1.14SolarisAttrReserved2
1.3.6.1.4.1.42.2.27.5.1.7SolarisAttrShortDesc
1.3.6.1.4.1.42.2.27.5.1.5SolarisAuditAlways
1.3.6.1.4.1.42.2.27.5.1.6SolarisAuditNever
1.3.6.1.4.1.42.2.27.5.1.20SolarisAuthMethod
1.3.6.1.4.1.42.2.27.5.1.18SolarisBindDN
1.3.6.1.4.1.42.2.27.5.1.19SolarisBindPassword
1.3.6.1.4.1.42.2.27.5.1.31SolarisBindTimeLimit
1.3.6.1.4.1.42.2.27.5.1.17SolarisCacheTTL
1.3.6.1.4.1.42.2.27.5.1.23SolarisCertificatePassword
1.3.6.1.4.1.42.2.27.5.1.22SolarisCertificatePath
1.3.6.1.4.1.42.2.27.5.1.24SolarisDataSearchDN
1.3.6.1.4.1.42.2.27.5.1.9SolarisKernelSecurityPolicy
1.3.6.1.4.1.42.2.27.5.1.15SolarisLDAPServers
1.3.6.1.4.1.42.2.27.5.1.27SolarisPreferredServer
1.3.6.1.4.1.42.2.27.5.1.28SolarisPreferredServerOnly
1.3.6.1.4.1.42.2.27.5.1.11SolarisProfileId
1.3.6.1.4.1.42.2.27.5.1.10SolarisProfileType
1.3.6.1.4.1.42.2.27.5.1.3SolarisProjectAttr
1.3.6.1.4.1.42.2.27.5.1.1SolarisProjectID
1.3.6.1.4.1.42.2.27.5.1.2SolarisProjectName
1.3.6.1.4.1.42.2.27.5.1.16SolarisSearchBaseDN
1.3.6.1.4.1.42.2.27.5.1.29SolarisSearchReferral
1.3.6.1.4.1.42.2.27.5.1.25SolarisSearchScope
1.3.6.1.4.1.42.2.27.5.1.26SolarisSearchTimeLimit
1.3.6.1.4.1.42.2.27.5.1.21SolarisTransportSecurity
1.3.6.1.4.1.42.2.27.5.1.12SolarisUserQualifier
2.16.840.1.113730.3.8.3.10sourceHost
2.16.840.1.113730.3.8.3.12sourceHostCategory
1.3.6.1.4.1.2428.20.1.99SPFRecord sPFRecord
1.2.840.113556.1.4.1347sPNMappings SPN-Mappings
1.3.6.1.1.1.1.52SRP-RFC5054-4096-SHA512-PBKDF2
1.3.6.1.4.1.2428.20.1.33sRVRecord
1.3.6.1.4.1.2428.20.1.44sSHFPRecord
1.3.6.1.4.1.24552.500.1.1.1.13sshPublicKey
2.5.4.8st stateOrProvinceName, State-Or-Province-Name, STRFC 4519, RFC 2256
2.5.4.9street streetAddress, streetaddress, Street-AddressRFC 4519, RFC 2256
1.2.840.113556.1.2.256streetAddress Address
2.5.21.9structuralObjectClass Structural-Object-ClassRFC 4512
← All categories