1034 entries · page 16 of 21

Object classes

Object classes define which attributes an entry may and must carry, from top down to inetOrgPerson and posixAccount.

OIDNameDefined in
2.16.840.1.113730.3.2.328nsSchemaPolicy
2.16.840.1.113730.3.2.94nsSimpleRoleDefinition
2.16.840.1.113730.3.2.39nsslapdConfig
2.16.840.1.113730.3.2.41nsslapdPlugin
2.16.840.1.113730.3.2.335nsSlapiTask
2.16.840.1.113730.3.2.43nsSNMP
2.16.840.1.113730.3.2.113nsTombstone
2.16.840.1.113730.3.2.45nsValueItem
2.16.840.1.113730.3.2.304nsView
2.16.840.1.113730.3.2.302nsYIMpresence
1.2.840.113556.1.5.71nTDSConnection NTDS-Connection
1.2.840.113556.1.5.7000.47nTDSDSA NTDS-DSA
1.2.840.113556.1.5.254nTDSDSARO NTDS-DSA-RO
1.2.840.113556.1.5.72nTDSService NTDS-Service
1.2.840.113556.1.5.69nTDSSiteSettings NTDS-Site-Settings
1.2.840.113556.1.5.153nTFRSMember NTFRS-Member
1.2.840.113556.1.5.102nTFRSReplicaSet NTFRS-Replica-Set
1.2.840.113556.1.5.89nTFRSSettings NTFRS-Settings
1.2.840.113556.1.5.155nTFRSSubscriber NTFRS-Subscriber
1.2.840.113556.1.5.154nTFRSSubscriptions NTFRS-Subscriptions
2.16.840.1.113730.3.2.9ntGroup
2.16.840.1.113730.3.2.8ntUser
1.3.6.1.4.1.4203.1.12.2.4.0.3olcBackendConfig
1.3.6.1.4.1.4203.1.12.2.4.0.0olcConfig
1.3.6.1.4.1.4203.1.12.2.4.0.4olcDatabaseConfig
1.3.6.1.4.1.4203.1.12.2.4.0.7olcFrontendConfig
1.3.6.1.4.1.4203.1.12.2.4.0.1olcGlobal
1.3.6.1.4.1.4203.1.12.2.4.0.6olcIncludeFile
1.3.6.1.4.1.4203.1.12.2.4.0.8olcModuleList
1.3.6.1.4.1.4203.1.12.2.4.0.5olcOverlayConfig
1.3.6.1.4.1.4203.1.12.2.4.0.2olcSchemaConfig
1.3.6.1.4.1.453.7.1.3omittedORAddressComponent tableEntryRFC 2164, RFC 2293
1.3.6.1.1.1.2.5oncRpc
1.3.6.1.4.1.4203.1.4.6OpenLDAPdisplayableObject
1.3.6.1.4.1.4203.1.4.3OpenLDAPorg
1.3.6.1.4.1.4203.1.4.4OpenLDAPou
1.3.6.1.4.1.4203.1.4.5OpenLDAPperson
2.5.6.4organization OrganizationRFC 4519, RFC 2256
2.5.6.7organizationalPerson Organizational-Person person plus the attributes an organization cares about: title, ou, postal address, telephone. It is the midpoint of the …RFC 4519, RFC 2256
2.5.6.8organizationalRole Organizational-RoleRFC 4519, RFC 2256
2.5.6.5organizationalUnit Organizational-Unit The container class behind the ou= levels of a tree. It is how you carve a directory into departments, sites, or tiers, …RFC 4519, RFC 2256
1.2.840.113556.1.5.49packageRegistration Package-Registration
2.16.840.1.113730.3.2.318pamConfig
2.16.840.1.113730.3.2.12passwordObject
2.16.840.1.113730.3.2.13passwordPolicy
1.3.6.1.1.9.1.54pcels8021FilterRFC 4104
1.3.6.1.1.9.1.10pcelsActionAssociationRFC 4104
1.3.6.1.1.9.1.45pcelsBitStringValueAuxClassRFC 4104
1.3.6.1.1.9.1.47pcelsBooleanValueAuxClassRFC 4104
1.3.6.1.1.9.1.15pcelsCompoundActionAuxClassRFC 4104
← All categories